微信扫码登录

其他登录方式

绑定手机号

注册

我同意用户协议

忘记密码

用户协议

绑定手机号

  • 公众号
  • 建议与合作

小程序丨wx.canIUse(String)

来源: 3269
关注
来源: 3269

wx.canIUse(String)接口使用的低版本到底是多少?请注意标注红色的版本号


我把开发工具上的基础库版本调成 1.0.0 或者 1.1.0 时,调用wx.canIUse(String)接口报下面的错误

wx.canIUse(String)


但是我把基础库版本调成 1.0.1 或比 1.1.0 版本更高是可以调用的,这究竟是什么鬼?

1.1.0 的版本使用不了,但是低版本1.0.1版本却可以使用…

是开发工具的BUG么?还是API的BUG?

网友回复:

T***:

哈哈,我遇到过了,只能这样了:

if(wx.canIUse){

    if(wx.canIUse(xxx)){

        ……………….

    }

}

C***:

1.x.0 是一个版本      

1.x.1 是对这个版本的 patch, 理论上1.x.1 会覆盖掉所有的 1.x.0

1.0.1 将覆盖 1.0.0  、 1.1.1 将覆盖 1.1.0


现网上会存在 .0 的版本,但是占比会逐渐缩小



爱盈利(aiyingli.com)移动互联网具影响力的盈利指导网站。定位于服务移动互联网创业者,移动盈利指导。我们的目标是让盈利目标清晰可见!降低门槛,让缺乏经验、资金有限的个人和团队获得经验和机会,提高热情,激发产品。

评论

京ICP备15063977号-2 © 2012-2018 aiyingli.com. All Rights Reserved. 京公网安备 11010102003938号